Thursday, April 13, 2006

New ATI driver 8.24.8 (Apr 12)

ATI Proprietary Linux x86_64 Display Driver for XFree86 / X.Org Version 8.24.8
download

release notes


howto install the ATI driver with SUSE Linux or SLED with XGL compiz here


SLED 10 Beta 9 - SL 10.1 Beta 9 - XGL
version 8.24.8 did not work for me
back to 8.23.7 - works

SLED 10 Beta 10 - SL 10.1 RC1 - XGL
version 8.23.7 - did not work for me
version 8.24.8 - GUI install and rpm install worked) - tried some new options in xorg.conf
Modules part and Device part from my /etc/X11/xorg.conf file

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
Load "dri"
EndSection

Section "Device"
BoardName "RV350 NP"
BusID "PCI:1@0:0:0"
Driver "fglrx"
Identifier "Device[0]"
Option "CRT2HSync" "31-48"
Option "CRT2Position" "Clone"
Option "SaXDualMonitorVendor" "--> VESA"
Option "SaXDualOrientation" "LeftOf"
Option "SaXDualResolution" "1024x768"
Option "SaXDualVSync" "50-60"
Option "CRT2VRefresh" "50-60"
Option "IgnoreEDID" "yes"
Option "MergedFB" "yes"
Option "SaXDualHSync" "31-48"
Option "MetaModes" "1400x1050,1024x768;1024x768,1024x768"
Option "SaXDualHead" ""
Option "SaXDualMode" "Clone"
Option "SaXDualMonitorModel" "1024X768@60HZ"
Option "KernelModuleParm" "agplock=0"
Option "no_dri" "no"
Option "VideoOverlay" "on"
VendorName "ATI"
EndSection






(Notes: How I switch drivers)
init 3
(Remove the ATI driver)
/usr/share/fglrx/fglrx-uninstall.sh
rpm -e $(rpm -qa | grep fglrx)

(Install the ATI driver)
rpm -uhv *.rpm --force --nodeps
cd/usr/src/linux
make clean
rpm -uhv *.rpm --force --nodeps
init 5

3 comments:

Anonymous said...

HEy Moose :)

The 8.24.8 driver works seemingly ok for me on SuSE 10.1 running on my hp nx6125 with a RADEON XPRESS 200M Series SW TCL Generic (thats what it tells me at least :).

Havent used Xgl on SuSE 10.1 yet,but I did on Ubuntu Dapper Drake and SLED beta 9 (where it took some/a whole load a effort) It appears running Xgl on this card without Compiz makes everything really slow and with Compiz it makes it unreliable tried using your Xgl sed script for a day or two but it kinda pissed me off to have to work on a basically buggy system. Would love to try Xgl again once the ati driver works better.

Regards,

Albert-Jan

nesnomis said...

Works! on my Noname (p4 2.8Ghz), on Radeon 9800 Pro, running SuSE 10.1 rc1, installed as usual... Downloaded installer, created RPM, installed, run sax2 -r -m 0=fglrx, reboot.... and swish... 8.24.8 is running... :-)

Have'nt run Xgl/compiz on my SuSE yet, as it simply does'nt work, need to test it on rc1! (Works nicely on Ubuntu Dapper though)...

Greets
nesnomis...

Outrider04 said...

Hey Moosy,

The 8.24.8 driver will work on 10.1 RC1 with a FireGL card in a TP43p, but without xgl and compiz. Installing the packages from CD 5 works as advertised but X won't start once the DISPLAYMANAGER_XSERVER parameter is changed to Xgl. I tried going back to 8.23.7 as you recommend but it won't complete the install, failing on a number of invalid pointers. No icon in Control Center to turn on XGL/Compiz any longer.

Same all true for Beta 10 (SLED Build 915) fyi

Cheers,

outrider04